What do you need help with?
Follow

Cyrus

Lyric users must run 2.0 firmware or greater. You can find instructions on how to download and install the latest firmware on the Cyrus website. Streaming devices must be running 4.0 firmware or greater. Your Cyrus retailer/distributor can update this device for you. Please note that the n-remote is no longer supported and a firmware update for TIDAL will disable it if it is being used.

TIDAL requires the latest version of Cadence (3.0.0 iOS, 2.0.0 Android or greater) to be running on your device. This can be updated via the App Store or Play Store.

Cyrus streamers are set to default to HiFi quality. If your bandwidth quality is poor, you may need to change the stream quality. This can be done in Cadence settings menu.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments